Windows XP Home OK, Windows 7 Pro Full Stop

23 Jan 2011

I have been developing an mbed project on a computer running Windows XP Home. The computer has crashed and burned. The new replacement is running Windows 7 Professional.

The mbed project ran fine and could be edited on the Windows XP Home. Windows 7 Pro can list the files that are on the mbed, but hangs up when trying to save to, copy to, or delete from the mbed.

My project has now stopped running although the mbed running light (LED) is on.

Anyone have any clues or suggestions?

I know pretty close to nothing.

23 Jan 2011

I don't have any problems with Win7 x64 Home.

23 Jan 2011

I have had difficulties withW7, I did manage to get MBED to go by deleting MBED in device manager. (2 or 3 times), seams to work now.

24 Jan 2011


I am up and running again.

26 Jan 2011

What was the cause of the problem?

26 Jan 2011

Windows 7 did not recognise the MBED Disk, and had a 'BAD USB Device' the cause, probably a paranoid Bill Gates .

28 Jan 2011

I have been able to write a new file to my mbed with Windows 7 Pro, but it seemed I could only write a file once. Then I had to disconnect and reconnect the mbed before I could write again.

At one time, Windows 7 said I did not have administrative rights to write to the mbed.

Tonight, neither Windows 7 nor Windows XP Home will write to the mbed. I get an "unable to copy because the file or directory is corrupted" message. Earlier tonight I was writing to the mbed from Windows XP but the mbed continued to run the old file, not the new file.

Totally lost.

28 Jan 2011

Hi David,

The best thing to try if you haven't already is to format the drive. It may have got corrupted if windows was writing to it when it was unplugged.

To do this, just right-click on the mbed disk icon in My Computer, and choose format. Assuming it does this, all should be back to normal. I'd recommend doing this on the XP machine if you were having problems on Win7.


28 Jan 2011

Thank you, Simon

Following your instructions, everything is back to normal and running fine on the Windos 7 machine.

05 Feb 2011

I continue to have constant problems editing the contents of my mbed thru the 'cloud' compiler from Windows 7 Pro. The problem seems to be in Window Internet Explorer 8. When the compiler offers the option to save the modified code, Internet Explorer 8 receives the file rather than it going straight to the mbed. The Internet Explorer then tries to write a copy to the mbed and gets hung up. Internet Explorer is working in 'Protected Mode.' If I turn off Protected Mode, the compiler 'save' gets hung up immediately.

My work around is to close everything down and disconnect the USB connection to the mbed. After half a dozen times, Internet Explorer, apparently, by chance, will let the compiler 'save' go to the mbed without interfering.

05 Feb 2011

Hi David,

Thanks for the report, and sorry you are having problems. It actually sounds like it is nothing to do with the compiler, but more to do with either IE or Windows trying to save a file to the mbed disk. I'm interested to know whether you think this is a problem with IE or Windows 7 Pro? Do you get the same problem when trying to save to your mbed from e.g. copying from the desktop? Or with a different browser?

We'll see if we can reproduce the problem on a similar platform our end and do some testing.


05 Feb 2011


Thanks for your reply.

I am convinced my problems are coming from Windows Internet Explorer 8. The 'cloud' compiler was working flawlessly for me until I migrated to Windows 7 Pro on a new machine. I would say that IE8 is checking the safety of the file for me before writing it to the mbed. But I don't know how turn off that feature or even locate it. /media/uploads/djgeenen/internetexplorer8.jpg I have tried to upload a screen grab of the menu window that comes up when the save tries to write to the mbed. From there all I can do is shut everything down with the task manager. Other windows can come up saying Intenet Explorer needs to restart and is off looking for a solution to the problem.

05 Feb 2011

Have you tryed Chrome, it works much better than IEn. On my Vista PC.


06 Feb 2011

Thanks for your suggestion, Ceri.

I did load and use Chrome and it was an improvement. It put the edited mbed file in a download area. I then copied it onto the mbed without trouble.

11 Feb 2011

Runs fine for me Win7 X64 Ultimate + Chrome

11 Feb 2011


I feel your are fortunate to have a computer that works well. I have moved my project to new Sony Vaio laptop running Windows 7 Pro and Intenet Explorer 8 and am no end of problems.

Now Chrome is behaving as IE8 did. When copying to the mbed, the copy process freezes. The only way I can get conrol back is to shut everything down with the task manager and start all over from the desktop. But this morning I can't seem to write a file to the mbed at all.

I am not a computer-scientist, only a computer-user.

And it is all getting 'too hard,' as we say in Australia.

11 Feb 2011

Having written all of the above, I have just had two normal edits to the med in a row from IE8.

12 Feb 2011

I use Win7 x64 with Firefox and don't have any problems.

16 Feb 2011

Hi, So far I haven't even been able to install the driver on my new Win 7 Pro Lenovo because when I plug in the mBed I get a bluescreen with white text saying something about an error ocuring and it shuts down. I tried to download the driver without plugging in the mbed but that also stall when it realises there isn't an mBed plugged in, at this point, if I plug in the mBed then I still get a repeat of the above. Help much appreciated Sam

02 Mar 2012


I am facing the same problem. I used to work with XP and I.E. on a DELL machine and everything was working fine. I recently moved to a WIN 7 x64 with a new DELL machine and I can load a project only one time. The second time, I have to disconnect the MBED because the PC is freezing.

I tried IE8 and Firefox; same freezing of the PC. I also try to format the MBED with Win7 and it didn't work properly.

If anybody has a solution, I'll take it :)

02 Mar 2012


its free, fast

02 Mar 2012

Hi Axel,

Check the cable!

If you take a look at:

One of the things that seems to have impacted a few Win7 users.

Hope that helps!


02 Mar 2012

I am pretty sure the Windows 7 problem comes from the mbed software being located in the Window 7 "Program Files" or Program Files (x86)" directories. These directories have been set up by Windows 7 and they are write protected. So a program running from those directories cannot write anything to something in that directory, hence, software doesn't work.

The solution, I believe, is to create a new directory, "Other Programs,"or "My Programs," and place the software you want to run in that dirctory. That software will then be able to write to files it is using in the same directory.

There is probably also a ""User Account Control" solution. But I have not mastered Üser Account Control."

This is my take on the situation and I am pretty much an idiot when it comes to Operating Systems, and the mysteries of Windows 7. Not so much an idiot, as I really didn't want to be a software engineer to use my computer.

I often wonder whether Microsoft ever uses it's own software.

03 Mar 2012

I just wanted to add that I've had this issue as well. I blamed it on all the serial port traffic (the only thing that seemed to be common in all the freezes) I did with my mBed but I had to just keep unplugging, plugging back in and hope it'll save. Couldn't delete, couldn't write, and I'm running Windows 7 Pro 64-bit and primarily use Firefox as browser but did try with chrome / opera and it was the same thing. I just wanted to post symptons and attempted fixes to help fix this problem in the future.

06 Mar 2012

All, Thanks for your help. I have just tried a shorter USB cable as suggested in the link given by Simon (see above). The MBED never freezed in that case.

  • Regular cable length: 2m
  • Short cable length: 20cm

Hope that will help !