blink_led template does not work on my NUCLEO-F030R8 board ?

10 Sep 2015

I do not know anyone who has a NUCLEO-F030R8 board, I hope the one who has the board can try the blink_led template code.

My conditions now is the basic blink code does not work on my board(ie. I can not see the LED blinking).

When I got the board, I uploaded the blink_led code and it worked OK, but the Nucleo_pwm did not work well, I have already posted in the question section. And I have not get a clue for it.

I have to say, I used ARM Keil to write a short program to test the chip, and it is OK.

I exported the MBED code to my computer and use keil to single step through the code, I found the execution is halted in this area:

0x08001254 1BC0      SUBS     r0,r0,r7
0x08001256 42B0      CMP      r0,r6
0x08001258 D85D      BHI      0x08001316
0x0800125A 6828      LDR      r0,[r5,#0x00]
0x0800125C 0380      LSLS     r0,r0,#14
0x0800125E D5F7      BPL      0x08001250
0x08001260 E00D      B        0x0800127E
0x08001262 F7FFFE0F  BL.W     HAL_GetTick (0x08000E84)
0x08000E84 4801      LDR      r0,[pc,#4]  ; @0x08000E8C
0x08000E86 6800      LDR      r0,[r0,#0x00]
0x08000E88 4770      BX       lr
// 0x08001262->0x08000E84  0x08000E88->0x08001254

I am really new to arm and its assembly. Can anyone give some help? Thanks ahead.

10 Sep 2015

Try switching revisions of the mbed lib in the online compiler (right mouse button, revisions), to 102 IIRC. I remember someone else reporting the same issue: Apparantly someone screwed up quite big and now on the F030 even a blinky fails.

10 Sep 2015

mbed 101 is the last version for which the blinky works:

10 Sep 2015

David, can you please report it here:, that's the issue tracker.

10 Sep 2015


11 Sep 2015

Thanks David Lowe mbed 101 is ok now. But mbed 102 not.

I do not know why setting this buggy lib as compiler default?

11 Sep 2015

If it was known to be buggy it wouldn't have been released...

Also it just sets latest stable release when you make a new program. That the latest stable release isn't stable wasn't known when it was set as latest stable.

Why they refuse to release platforms with as excuse that they can't properly test it, even though almost same MCU can be tested, while other platforms which they can test they apparantly don't test, is not something I understand. But then I gave up understanding mbed decisions long ago.

11 Oct 2015

Hi All,

I'm having problems with the change from rev 95 to 96 using my Nucleo F103 board. The problems arise when I export to Keil v5.14 - it won't compile any more (this is a simple blinky example, shown below).

Simple Blinky, library rev 108

#include "mbed.h"
// built with mbed 108
DigitalOut myled(LED1);

int main() {
    while(1) {
        myled = 1; // LED is ON
        wait(0.2); // 200 ms
        myled = 0; // LED is OFF
        wait(1); // 1 sec

I've worked my way back through the revisions until I found one that works. It lines up with mbed's move to Cube, I think, because the error is about a missing hal file:

.\build\Nucleo_blink_led.axf: error: L6002U: Could not open file mbed/TARGET_NUCLEO_F103RB/TOOLCHAIN_ARM_MICRO/stm32f1xx_hal_u: No such file or directory

Any version of the official mbed library >95 seems to show this error.

I have Middleware v6.5.0, CMSIS 4.4.0 and STM32F1xx_DFP 1.1.0

Reverting to earlier versions of Keil (v5.11) solves the problem, but its not ideal.