Cool Components Workshop Board

14 Jan 2011 . Edited: 14 Jan 2011


I have one of these Workshop Boards (version 2). To test out the LAN connection I tried to compile the "Ethernet Jack Test Code" at "" and it failed with the message:

"Cannot open source input file "core/net.h": No such file or directory (E5) <a href="#" onClick="'/cookbook/Compiler-Error-5');">(more info)</a>" in file "lib/HTTPClient/LPC1768/services/http/client/HTTPClient.h" at "Location Line:33, Col:21"

There is a line "#include core/net.h" in the code for "LPC1768/services/http/client/HTTPClient.h" line 33, but a search for 'core/net.h' on the mbed website fails to find a reference.

Please and Thanks for any help

15 Jan 2011

Hello Harry, sounds like an incomplete IP-stack. You probably imported only the HTTPClient?

15 Jan 2011

Thank you for your reply - I am keeping you busy!

The code - that headed "Ethernet Jack Test Code :" on the page "" has only the two includes ..

  1. include "mbed.h"
  2. include "HTTPClient.h"

.. so I have to ask what extra ones are missing and why aren't they in this set?

I had a problem with 'Import' which I posted here earlier, but after Michel's suggestion I have overcome that - see my next post, so I have removed the image to reduce space taken up.

15 Jan 2011

Hello Harry,

I got the same error this morning for another import. After a second try, it worked.

15 Jan 2011

Hello Michel Jank

Thank you for the post. I have now got it going. After looking to see if firewalls etc might be doing it I tried logging out of mbed, closing all windows, and starting from scratch - no problem this time. Thanks again, Harry

16 Jan 2011

Louis Lagendijk L wrote:

Hello Harry, sounds like an incomplete IP-stack. You probably imported only the HTTPClient?

Hello Louis. Thanks for your reply, there. I have searched, but I cannot see what imports I have omitted, can you tell me, please, which are missing? Thanks and best wishes, Harry

16 Jan 2011

Which libraries have you imported into your program?

16 Jan 2011

Thanks for your prompt reply. At first only the two in the '#includes' in the code (.cpp) file:

#include "mbed.h"
#include "HTTPClient.h"

After reading your post I added ..

#include "EthernetNetIf.h"

.. as the only other one I could see that might be relevant...

Best wishes, Harry

16 Jan 2011

Actually I meant which libraries you have added to your project, and not the includes. Since the error comes not from your source, but from an included file, I don't think adding another include will help.

17 Jan 2011

Hello again

I saw your message last night, but it was late at night so I went to bed. Thanks again for your prompt response.

I am an 80 year old novice floundering a bit out of my depth here, so I don't know what you mean by "which libraries you have added to your project", not sure how I do that, and which libraries apply. I'd be grateful for more details, thanks for your trouble, and best wishes, Harry

18 Jan 2011

When you have a program in your mbed IDE, you can add libraries to it (right mouse-click, 'add library'). I think you did it with the HTTP-client, because otherwise you would not have a 'HttpClient.h' available. I just wanted to know which libraries you have in your program.

19 Jan 2011

Hello. Thank you for continuing to assist me as I flounder about here. I am not sure what I have missed out. Here is a picture of the panel that applies to this, on its side to save space.


Thanks again best wishes, Harry

18 Jan 2011

Can you try removing EthernetIf and HTTPCLient, and use the NetServices library instead? It contains the whole netwroking stack, and all the client code - especially everything the HTTPClient needs.

18 Jan 2011

Thanks yet again. I composed a (longish) reply here, but careless use of the delete key made it disappear, now it's lost somewhere, and time has run out. I will have to leave it until tomorrow, sorry, Best wishes, Harry

19 Jan 2011

Hello Hendrik again, sorry for the delay. I have been using the program "Ethernet Jack Test Code" copied (Ctl-C and Ctl-V) from the web page "", and I have added the "NetServices" library you suggested to my Program Workspace, and now get this compiler output:/media/uploads/ColonelPewter/clcptserrors.jpg

I don't have the deep knowledge of how the compiler operates on these libraries to sort out for myself what is going on (and the "more info" simply shows a blank screen). If you still have the patience to continue to look at it I'd would again be grateful, as I am for the help you have given so far. Best wishes, Harry

19 Jan 2011

This code seems to refer to a pretty old version of the networking code. I have published a compilable program (though not tested) here.

21 Jan 2011

Hello Hendrik. I tried that out, and it did compile, but a run failed with the rather un-informative message "Error 3" alone on my Tera Term screen.

I think, now, that I am at the end of the road for this project. I started off to try to read the time from my PC via a LAN, to set the mbed clock, and I have achieved that thanks to the help of you and others, so now I must get on with other things. Thank you again for your patience, trouble and help, best wishes, Harry