mbed DOA?

25 Oct 2010

Hi there,

I just unpacked my new mbed, and I am having trouble getting it to do anything at all.

It won't even blink LED1 when I drop the HelloWorld_LPC1768.bin program on it.

The LED in the middle is lit and flickers when I write to the file system (which turns up fine).

I can also connect to the virtual serial port, even though it does not produce any output.

Strangely enough, LEDs 1 to 4 are lit up very faintly, and the LPC1768 does not seem to respond at all.

Any tips? Any suggestions on how to find out if the H/W is OK?

 

Thanks,

Ard.

26 Oct 2010

Did you hit the reset pushbutton on the mbed module after downloading? I have seen a couple that seem to take a couple hits or a harder hit to reset. And when the button is down, the LED in the middle should go out until you release it.

 

 

26 Oct 2010

The LED does go out when I push the reset button but no matter how long or how many times I press it, nothing happens.

26 Oct 2010

Have you tried another USB port, have you tried it on another PC? 

26 Oct 2010

yes,

i have tried on both mac and linux

26 Oct 2010

Hi Ard,

I've just started a cookbook page called deadmbed to help try and track down these problems; hopefully it can grow over time to cover more cases. Perhaps you can have a look at that, and we can expand it as we track down your problem!

We actually get very few hardware failures, so it'd be good to track this one down. It does sound a bit strange. Please send us an email at support@mbed.org with your results and we'll get you up and running...

Simon

19 Jul 2013

I found a possible cause of this problem today for anyone googling the same thing - caused by using two or more mbeds on the same account.

If you've added an mbed of one type (in my case it was the LPC1768) and then at a later time tried to compile code onto a different model (like the LPC11U24) then the second mbed will behave exactly as described here - all LEDs dimly on, programming and resetting causes LED to flash but nothing will be output.

Obviously the compiler produces different binary files for the different development boards, so check in the top right hand corner of the online compiler to see which development board you're compiling for, and remember to add the key to your account by clicking the mbed.htm file on the device.

I'm using the mbed in a university setting where I'm programming various boards, and a couple of people had the same problem so I thought I'd post it here in case anyone finds it useful.

You need to log in to post a reply