Thread.start crashes - triggers error blink code

12 Nov 2019

Hi there. I've been encountering an error in some other code and I narrowed it down to the Thread.start method call.

I've trimmed it down to a 23-line example that reproduces the problem. I narrowed it down to the Thread.start call in a more complex program with other IO.

I do not have a debugger yet, so I'm sort of limited in what I can do. This code _should_ work, so I suspect it may actually be a problem with my development environment on my Mac. I use the mbed-cli tools' mbed command to import the mbed code and start the project, and I'm using the latest version of the arm tools.

I've tested the code with older versions of the arm tools as well and I have the same error - the four fast four slow blink code on LED1. Interestingly enough, though, LED2 is lit when this crashes. It starts with LED1 and LED2 off.


I'm using an STM32F407VET6 "Black" board and I've compiled mbed code that does not use the Thread class and it works just fine.

Can someone compile this on a Windows machine and see if it works? I only have a Mac available to me until I go to work in the morning.


25 Nov 2019

Hi Glyn,

I don't have STM32F407, so I tried your program on my K64F, built with online compiler, it works fine, are you still facing this issue?

Regards, Desmond