There needs to be a way to flag accounts/answers as spam

29 Nov 2017

While it's possible to report questions or forum posts there is no way to report answers to questions as being spam or user accounts as being created purely for creating spam.

e.g. https://os.mbed.com/users/MarkRoger/ is clearly a spam account but with only one post so far, an answer to a question. As such there is no way to report the post or the user in order to remove the spam or delete the account.

I am working on the assumption that no one here want's to pay a website to do their homework and then have to explain to the person marking it why their grammar suddenly became quite so bad.

29 Nov 2017

Hey Andy,

We agree. We are working on a fix internally, and you should see changes soon. Thank you for flagging this, and I'm sorry for any inconvenience.

04 Jan 2019

This seems to be broken. In the thread "https://os.mbed.com/questions/83851/cannot-mount-nucleo-f401re-under-mac-os-/#answer15850" i can report the original question al spam and my own answer (which is kind of strange). but *not* the oblivious spam. There is no "Report spam" button there.

04 Jan 2019
04 Jan 2019

I'm still waiting for the changes that were coming soon over a year ago...

23 Jan 2019

It is possible to report individual answers as SPAM/inappropriate. There is a "report" button above and to the right of each answer. Please let us know if you are not able to access this functionality.

Tres, Team Mbed

23 Jan 2019

With the right permissions, it should also be possible to report a user as a spammer.

Tres, Team Mbed

23 Jan 2019

Where is the link or button ?

For example : https://os.mbed.com/users/cemllyrios/ has been posting spam (the answers have nothing to do with the questions and are copied fro other answers). How do i report this user ?

Kind regards, Ivo

23 Jan 2019

Hi Ivo,

If you have permission there should be a button to identify a user as a spammer.

Tres, Team Mbed

23 Jan 2019

Here is the image:

23 Jan 2019

There is no red button./media/uploads/ivo_n/mbed_no_report_user.png

I think you are using an account with extra options. Maybe you can make a new, normal, account and check if the option is there.

Kind regards, Ivo

23 Jan 2019

You are right. It is not possible to report a SPAM user using a regular account. I will report this, and work to get an answer as soon as possible. Thank you for wanting to help Arm to eliminate SPAM.

Best regards,

Tres, Team Mbed

23 Jan 2019

In the meantime, I have made some edits to the posts (above) and marked the referenced user as a spammer. His account will be removed shortly, and I will respond (on this thread) as soon as we have a procedure for allowing the community to report spammers.

Best regards,

Tres, Team Mbed

28 Jan 2019

Tres Hill wrote:

It is possible to report individual answers as SPAM/inappropriate. There is a "report" button above and to the right of each answer. Please let us know if you are not able to access this functionality.

Tres, Team Mbed

Just FYI the report button shows up for questions and all forum posts but doesn't show up for answers to questions.

15 Mar 2019

We were told that we would see changes to fix this soon and then nothing happened for 2 years.

So does "I will report this, and work to get an answer as soon as possible." also mean 2 years or more?

Is it really that hard to add a report button to question answers?

Please log in to post a reply.