can't open compiler

09 Oct 2010

When I open compiler I get an error "ERROR: Failed to initialize control objects.Failed to load store file."

Browser is Google Chrome 6.0.472.63 and Safari 5.0.2 on OSX

Hello mbed,

Mr.bontakun tried another acount on same environment.  -->  It didn't show any problem to load the compiler page.

So it seems it is not the user environment problem but the user account on mbed.org. There may be an object that cause of error when open the compiler.
Please check the files or settings for this user.

Thanks in advance & rgs / nxpfan

11 Oct 2010

Have exactly the same and have send a mail to support@mbed.org. It started when I opened an example with a lot of Chinese characters.

Ben Zijlstra

 

11 Oct 2010

Hi,

Sorry about that - we are looking into the problem and hope to have a fix available soon. In the meantime, you might try the previous version of the compiler, following the instructions at http://mbed.org/forum/bugs-suggestions/post/5690/

Thanks,

Dan

11 Oct 2010

Doesn't work for me. After a roll back I get a Fatal Application Error.

Will wait for further instructions.

 

11 Oct 2010

Hi Dan,

After rolling back to the old compiler I got possible to look at the compiler page.

However,I get a new error "Fatal Application Error: Resource object failed to load. Please contact support and describe how you get this message."

I will wait for instructions.

 

 

 

11 Oct 2010

Dan

Here the pictures you asked for:

Picture above: before rollback

Picture above: after roll-back starting compiler

Picture above: after clicking OK. A empty environment.

Picture above: after creating a new program.

 

11 Oct 2010

It is same as Mr. Ben.

The fatal Application Error seems to have occurred when my programs is refreshed.

Can my programs be cleared?

11 Oct 2010

Hi,

I've fixed the problem with the rollback compiler - you should be able to create new programs now in rollback mode.

I will try and get a solution for the 'control objects' problem today. I will update this thread as soon as I have more info.

Dan

11 Oct 2010

Hi Dan,

I can create new programs now.

But I still get a Fatal Application Error. So, I can not view later a new programs.

I look forward to updates.

Thanks,

 

 

 

12 Oct 2010

Hi,

I have temporarily fixed the issue for both bontakun and Ben.

The problem is related to having more than one compiler window open at once, so if you avoid that for now, the problem should not reoccur.

We are still working on a code fix for this problem, but hopefully the problem will be fixed properly very soon. If anyone else encounters this issue, please raise a support ticket or post here, and I will apply the fix to them too.

Thanks,

Dan

12 Oct 2010

Hi Dan,

Ihave to make sure that all operations are normal.

Thanks for your supports.

12 Oct 2010

Hi Dan,

All is working again. Glad you found the solution!! Thanks!!!

 

 

You need to log in to post a reply