Mistake on this page?
Report an issue in GitHub or email us
Macros
Version macros

Macros

#define MBED_MAJOR_VERSION   5
 MBED_MAJOR_VERSION Mbed OS major version. More...
 
#define MBED_MINOR_VERSION   11
 MBED_MINOR_VERSION Mbed OS minor version. More...
 
#define MBED_PATCH_VERSION   5
 MBED_PATCH_VERSION Mbed OS patch version. More...
 
#define MBED_VERSION   MBED_ENCODE_VERSION(MBED_MAJOR_VERSION, MBED_MINOR_VERSION, MBED_PATCH_VERSION)
 MBED_VERSION Mbed OS 5 version (MMmmpp - M(Major); m(minor); p(patch)) More...
 
#define MBED_VERSION_CHECK(major, minor, patch)
 MBED_VERSION_CHECK Macro can be used to check minimum Mbed OS version required for feature/library. More...
 

Detailed Description

Macro Definition Documentation

#define MBED_MAJOR_VERSION   5

MBED_MAJOR_VERSION Mbed OS major version.

Note
99 is default value for development version (master branch)

Definition at line 33 of file mbed_version.h.

#define MBED_MINOR_VERSION   11

MBED_MINOR_VERSION Mbed OS minor version.

Note
99 is default value for development version (master branch)

Definition at line 40 of file mbed_version.h.

#define MBED_PATCH_VERSION   5

MBED_PATCH_VERSION Mbed OS patch version.

Note
99 is default value for development version (master branch)

Definition at line 47 of file mbed_version.h.

#define MBED_VERSION   MBED_ENCODE_VERSION(MBED_MAJOR_VERSION, MBED_MINOR_VERSION, MBED_PATCH_VERSION)

MBED_VERSION Mbed OS 5 version (MMmmpp - M(Major); m(minor); p(patch))

Note
999999 is default value for development version (master branch)

Definition at line 56 of file mbed_version.h.

#define MBED_VERSION_CHECK (   major,
  minor,
  patch 
)
Value:
do { \
MBED_STATIC_ASSERT((MBED_VERSION >= MBED_ENCODE_VERSION((major),(minor),(patch))), "Incompatible mbed-os version detected!!"); \
} while(0)
#define MBED_VERSION
MBED_VERSION Mbed OS 5 version (MMmmpp - M(Major); m(minor); p(patch))
Definition: mbed_version.h:56

MBED_VERSION_CHECK Macro can be used to check minimum Mbed OS version required for feature/library.

If current version is less than required, it will assert.

Note
: Version of master branch will be 999999 as default, hence no assert/warning is provided for master branch code

Definition at line 65 of file mbed_version.h.

Important Information for this Arm website

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies. If you are not happy with the use of these cookies, please review our Cookie Policy to learn how they can be disabled. By disabling cookies, some features of the site will not work.